Написать программу с помощью цикла с предусловием (while). Вычислить сумму чисел в диапазоне от 19 до 51, если они делятся на 5.
// F# open System [] let main argv = let mutable sum = 0 let mutable i = 0 let array = [19..51] while i < array.Length do let value = array.Item i if 5 % value = 0 then sum <- sum + value<br> i <- i+1<br> Console.WriteLine sum Console.ReadKey true |> ignore 0 // Pascal (for) var sum : integer; i: integer; begin sum := 0; i := 0; for i:=19 to 51 do begin if i mod 5 = 0 then sum := sum + i; end; writeln(sum); end. // Pascal var sum : integer; i: integer; begin sum := 0; i := 19; while (i <= 51) do<br> begin if i mod 5 = 0 then sum := sum + i; i := i + 1; end; writeln(sum); end.
добавил паскаля, даж много впоимнать не пришлось
спасибо тебе огромное!!!
ахаха, это цикл с известным количеством повторений, а нужно с предусловием..
while tn ybult((
while нет нигде((
о точно забыл ужо, добавил
спасссиииииибо))))))
цикл с известным количеством повторений все ты знаешь, чего ж написать то не можешь?:)
ахаха, умные слова, не правда ли? Что то у меня ничего не получается, если я сама делаю)) а теорию я знаю отлично))
еще раз большое спасибо за помощь!