Написать программу с помощью цикла с постусловием (repeat). ПАСКАЛЬ Вычислить сумму чисел...

0 голосов
129 просмотров

Написать программу с помощью цикла с постусловием (repeat). ПАСКАЛЬ
Вычислить сумму чисел в диапазоне от 19 до 51, если они делятся на 5.


Информатика (420 баллов) | 129 просмотров
0

включительно?

0

да

Дано ответов: 2
0 голосов
Правильный ответ

Var a,b,c:
integer;
begin
a:=19;
b:=0;
repeat
if (a mod 5 = 0) then
b:=a+b;
a:=a+1;
until (a>52);
writeln(b);
end.

(8.6k баллов)
0 голосов

// Pascal
  var sum : integer;
      i: integer;
begin
  sum := 0;
  i := 19;
  repeat
    if i mod 5 = 0 then
      sum := sum + i;
    i := i + 1;
  until (i > 51);
  writeln(sum);
end.

(1.4k баллов)