Кто смыслит в ИНФЕ ПОМОГИТЕ!!! Написать программу, позволяющею по последней цифре числа...

0 голосов
83 просмотров

Кто смыслит в ИНФЕ ПОМОГИТЕ!!!
Написать программу, позволяющею по последней цифре числа определить последнюю цифру его квадрата.
_______________________________________________
Вот примерно я написал, а дальше не могу!!!
uses crt;
var a,b: integer;
begin
writeln('Bведите a');
readln(a);
case b of
.......
Допишите та буквально 2-3 строки еще без end...


Информатика (69 баллов) | 83 просмотров
Дан 1 ответ
0 голосов

Uses crt;
var a,b: integer;
begin
writeln('Bведите a');
readln(a);
b := a mod 10;
b := b * b;
b := b mod 10;
write('Последняя цифра квадрата: ');
writeln(b);
end.

Вариант с CASE:
uses crt;
var a,b: integer;
begin
writeln('Bведите a');
readln(a);
b := a mod 10;
write('Последняя цифра квадрата: ');
case b of
0: writeln(0);
1: writeln(1);
2: writeln(4);
3: writeln(9);
4: writeln(6);
5: writeln(5);
6: writeln(6);
7: writeln(9);
8: writeln(4);
9: writeln(1);
end;
end.

(560 баллов)
0

Мне именно с CASE надо

0

изврат с CASE :(((

0

поправил

0

ну прога работает))) все равно спс