Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве...

0 голосов
599 просмотров

Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Входные данные

Сначала задано число N — количество элементов в массиве (1N100). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные

Необходимо вывести количество элементов массива, у которых два соседа и которые при этом строго больше обоих своих соседей.
Примеры
Входные данные
5
1 2 3 4 5
Выходные данные
0
Входные данные
5
1 5 1 5 1
Выходные данные
2


Информатика (50 баллов) | 599 просмотров
Дан 1 ответ
0 голосов

Var i,num,s:integer;
    arr:array of integer;
begin
  readln(num);
  setlength(arr,num);
  for i:=0 to num-1 do begin
    read(arr[i]);
    if i>1 then begin
      if (arr[i-2]    end;
  end;
  writeln('',s);
end.

(3.2k баллов)
0

Спасибочки огромное :3

0

#include
using namespace std;
int a[1000];
int main ()
{
int n;
cin >> n;
for(int i=1;i<=n;i++)<br> {
cin >> a[i];
}
int k =0;
for(int i=1;i<=n;i++)<br> {
if(a[i-2] {
k = k + 1;

}

}
cout << k;<br> return 0;
}