Написать программу в паскале, используя repeat until . Задача: Дана непустая...

0 голосов
35 просмотров

Написать программу в паскале, используя repeat until . Задача: Дана непустая последовательность, оканчивающаяся нулем. Найти в ней минимальную цифру.


Информатика (311 баллов) | 35 просмотров
Дан 1 ответ
0 голосов

var x,min:integer;
begin
min:=999999;
repeat
readln(x);
if (min>x) and (x<>0) then min:=x;
until x=0;
writeln(min);
end.

(9.9k баллов)