Напишите программу, которая по заданному натуральному n печатает первые n чисел...

0 голосов
36 просмотров

Напишите программу, которая по заданному натуральному n печатает первые n чисел последовательности 1, 2, 4, 8, 16, 32.
В первой строке содержится n (1 ≤ n ≤ 50) – количество чисел.
Вывести первые n чисел геометрической прогрессии со знаменателем 2 и первым членом 1.
с++


Информатика (12 баллов) | 36 просмотров
Дан 1 ответ
0 голосов
#include

int main()
{
int n, i;

scanf("%d", &n);

if (n>=1&&n<=50)<br>{

for (i=1; i<=n;i*=2){</span>
printf("%d ", i);
}
}
return 0;
}


(314k баллов)