Дано трехзначное число.Кратна ли 5 сумма его чисел.НАДО СДЕЛАТЬ ЧЕРЕЗ ПРОГРАММУ...

0 голосов
111 просмотров

Дано трехзначное число.Кратна ли 5 сумма его чисел.НАДО СДЕЛАТЬ ЧЕРЕЗ ПРОГРАММУ ПАСКАЛЬ(написать программу) помогите плиз


Информатика (299 баллов) | 111 просмотров
Дан 1 ответ
0 голосов

Var a, sum : integer;
begin
readln(a);    - считываем данное число
sum := (a div 100) + ((a mod 100) div 10) + (a mod 10); - сумма цифр
if (sum mod 5 = 0) then writeln('yes') else writeln('no'); - проверка делимости на 5
end.

(440 баллов)