Составить программу ** языке Паскаль. Просто помогите! Умоляю! 1)Составить программу...

0 голосов
95 просмотров

Составить программу на языке Паскаль. Просто помогите! Умоляю! 1)Составить программу ввода букв или цифры,или спецзнака. Выводить сообщение типа"Это цифра..."," Это буква..",или "Это спецзнак..". К сообщению добавлять саму цифру,букву,спецзнак.
2)У белых на доске остался король,а у черных король и ферзь. Охарактеризовать положение белых с помощью одного из слов шах,мат,пат,обыкновенная позиция


Информатика (64 баллов) | 95 просмотров
0

Вы тут собираетесь все 20 задач решать? Или это избранное?

0

Возможно,но они есть похожие,и да это избранное, просто где еще искать ответы,если здесь даю верные решения

0

Например, что-то и самостоятельно решать

0

У менЯ решено 2 задачи. Эти задачи,которые написаны здесь имеются похожие к ним в зачете

0

Это прост самые непонятные

0

По второй задаче: ввод данных, проверка допустимости позиции (короли не соприкасаются), оценка, находится ли под боем король белых, если да, может ли он уйти на безопасное поле или убить незащищенного черным королем ферзя, если нет - мат, если да - то шах. Если король белых не под боем и может пойти на безопасное поле - обыкновенная позиция, иначе пат.

0

Все эти оценки надо проводить в терминах элементов массива 8х8, имитирующего шахматную доску.

0

Для программирования подобных задач каждая фигура снабжается собственной мини-доской ходов, а потом эти доски накладываются на общую и рассматривается наложение полей.

0

В общем, все очень сложно даже для понимания.

0

А первую,хотябы помогите

Дан 1 ответ
0 голосов
Задача 1, Pascal.ABC.Net

const
  sAlpha='abcdefghijklmnopqrstuvwxyzабвгдеёжзийклмнопрстуфхцчшщъыьэюя';
  sDigit='0123456789';
var
  c,c1:char;
begin
  Write('Введите символ: '); Readln(c);
  c1:=LowerCase(c);
  if Pos(c1,sAlpha)>0 then Writeln('Введена буква ',c)
  else
    if Pos(c1,sDigit)>0 then Writeln('Введена цифра ',c)
    else Writeln('Введен спецсимвол ',c)
end.

Программирование задачи №2 - большая работа, требующая многих часов, если не имеется готовых наработок для программирования шахматной игры. Давать подобные задачи для решения на данном Сервисе - бесполезное занятие, такое не задают даже на олимпиадах.
(142k баллов)