Написать программу паскаль, которая поменяет местами А и В, без использования третьей...

0 голосов
66 просмотров

Написать программу паскаль, которая поменяет местами А и В, без использования третьей переменной.(программа + блоксхема)


Информатика (15 баллов) | 66 просмотров
0

Таких способов даже несколько.

0

напиши самый легкий, пожалуйста

Дан 1 ответ
0 голосов
Правильный ответ

Var
  a,b:integer;
begin
  readln(a,b);
  a := a+b;
  b := a-b;
  a := a-b;
  writeln(a,' ',b)
end.

Блок-схема во вложении


(142k баллов)