Паскаль абц Ввести несколько чисел. Вывести числа от 20 до 75, кратные 4

0 голосов
52 просмотров

Паскаль абц
Ввести несколько чисел. Вывести числа от 20 до 75, кратные 4


Информатика (32 баллов) | 52 просмотров
Дан 1 ответ
0 голосов

Var N, i: integer; // N - переменная хранения количества чисел, которое введет пользователь
A: array[1..20] of integer; // массив, содержащий САМИ ЧИСЛА, которые введет пользователь 
begin
write('Сколько чисел вы собираетесь ввести? ');
readln(N); 
for i := 1 to N do begin
write('Введите ', i, ' число: '); // ввод чисел
readln( A[ i ] );
end;
write('Из них числа от 20 до 75, кратные 4: ');
for i := 1 to N do begin
if ( A[ i ] >= 20 ) and ( A[ i ] <= 75 ) then // проверяем в каком промежутке лежит число<br>if ( ( A[ i ] mod 4 ) = 0 ) then write( A[ i ], ' '); // если число меньше 75 и больше 20, тогда проверяем кратно ли оно четырем. Если да, то выводим его
end;
end.

(2.3k баллов)