Помогите пожалуйста написать программу ** ПАСКАЛЕ: вычислить 15 значений функции y=2-sin...

0 голосов
59 просмотров

Помогите пожалуйста написать программу на ПАСКАЛЕ: вычислить 15 значений функции y=2-sin x из диапазона [pi/4, pi/2]


Информатика (15 баллов) | 59 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
  pi=3.14159265;
  n=15;
var
  a,b,h,x,y:real;
begin
  a:=pi/4; b:=pi/2;
  h:=(b-a)/(n-1);
  x:=a;
  while x<=b+h/2 do { h/2 - компенсация накопления погрешности }<br>  begin
    y:=2-sin(x);
    Writeln(x:7:5,y:8:5);
    x:=x+h
  end
end.

Результат выполнения программы:
0.78540 1.29289
0.84150 1.25436
0.89760 1.21817
0.95370 1.18444
1.00980 1.15328
1.06590 1.12478
1.12200 1.09903
1.17810 1.07612
1.23420 1.05612
1.29030 1.03908
1.34640 1.02507
1.40250 1.01413
1.45860 1.00629
1.51470 1.00157
1.57080 1.00000

(142k баллов)