Написать в программе Паскаль: Пирожок в столовой стоит а рублей и b копеек. Определите,...

0 голосов
81 просмотров

Написать в программе Паскаль:
Пирожок в столовой стоит а рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n пирожков. Программа получает на вход три числа: а, b, n и должна вывести два числа: стоимость покупки в рублях и копейках


Информатика (840 баллов) | 81 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Program zadanie;
Var a,b,n:integer;
Begin 
Writeln('Введите стоимость пирожка в рублях и копейках'); 
Readln(a,b); 
Writeln('Сколько нужно купить пирожков'); 
Readln(n); 
Writeln('Стоимость покупки в рублях=',n*a+((b*n) div 100)); 
Writeln('Стоимость покупки в копейках=',(n*b) mod 100);
End.

(258 баллов)
0 голосов

A, b, n, s1, s2 :integer;
begin
write('введите стоимость пирожка в рублях ');
readln(a);
write('введите стоимость пирожка в копейках ');
readln(b);
write('введите количество пирожков ');
readln(n);
s1:=a*n;
s2:=b*n;
writeln('стоимость покупки в рублях ', s1);
writeln('стоимость покупки в копейках ', s2);
end.

(106 баллов)