(30 БАЛЛОВ!)Задание: составить программу ** языке Паскаль для решения следующей задачи:...

0 голосов
52 просмотров

(30 БАЛЛОВ!)Задание: составить программу на языке Паскаль для решения следующей задачи: задать одномерный массив случайным образом, элементы которого принадлежат промежутку [-30;40];
найти количество элементов массива, принадлежащих промежутку [-10;25).


Информатика (98 баллов) | 52 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
    n = 3;
var
  i,s:integer;
  a:array[1..n] of integer;
begin
  s:=0;
  for i:=1 to n do
   begin
     a[i]:=random(71)-30;
     if (a[i]>=-10) and (a[i]<25) then s:=s+1;<br>   end;
  writeln('Полученный массив:');
  for i:=1 to n do
   write('a[':4,i,']=',a[i]);
  writeln;
 write('Промежутку [-10;25) принадлежат ',s,' элемент(ов)');
end.

(2.0k баллов)
0

Изумительно!