Написать программу в Паскале abc. вывести ** экран все двузначные числа, сумма цифр...

0 голосов
107 просмотров

Написать программу в Паскале abc. вывести на экран все двузначные числа, сумма цифр которых равна заданному числу n


Информатика (228 баллов) | 107 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Блин! Начал писать программу, а комп ВЫЛЕТЕЛ....
Поэтому припоздал....


uses Crt;
var i, n, m, z1, z2 :integer;

begin
 ClrScr;
 Write (' n = ');
 ReadLn(n);
 WriteLn;
 if (n<0) or (n>18) then WriteLn (' None!')
 else begin
      for i:=11 to 99 do
         begin
           m:=i;
           z1:=m div 10;
           z2:=m mod 10;
           if (z1+z2=n) then Writeln(' m = ', m);
         end;
      end;
 ReadLn;
end.

0 голосов

Var
i,j,n:integer;
begin
read(n);
for i:=1 to 9 do
for j:=0 to 9 do
if i+j=n then
Writeln(i,j , ' = ', n);
end.

(160 баллов)
0

А разве 50 не двузначное число??? Почему цикл начинается с 1?

0

Точно, вы правы.