1. Построить и записать в виде программы алгоритм вычисления суммы квадратов десяти...

0 голосов
75 просмотров

1. Построить и записать в виде программы алгоритм вычисления суммы квадратов десяти произвольных чисел, вводимых с клавиатуры в процессе выполнения программы.
2. Вводятся 15 чисел. Определить, сколько среди целых чисел.
3. Вывести все четные числа начиная с числа N и до числа M. Числа N и M задает пользователь.
4. Составить программу, печатающую все делители целого числа в порядке возрастания


Информатика (12 баллов) | 75 просмотров
Дан 1 ответ
0 голосов

На паскале.
1)
var i, n, sum : integer;
begin
sum := 0;
for i := 1 to 10 do
begin
readln(n);
sum := sum + n * n;
end;
writeln(sum);
end.
2) 
var i, sum : integer;
n : real;
begin
sum := 0;
for i := 1 to 15 do
begin
readln(n);
if n = trunc(n) then sum := sum + 1;
end;
writeln(sum);
end.
3) var n, m, i : integer;
begin
readln(n, m);
for i := n to m do
if i mod 2 = 0 then writeln(i);
end.
4) var n, i : integer;
begin
readln(n);
for i := 1 to n do
if n mod i = 0 then writeln(i);
end.

(204 баллов)