Написать программу, которая по введенному значению аргумента вычисляет значение функции,...

0 голосов
150 просмотров

Написать программу, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика. Параметр R вводится с клавиатуры.


image

Информатика | 150 просмотров
Дан 1 ответ
0 голосов

#include
      using namespace std;
      int getSum(int i){
              int ans = 0;
              do{
                      ans+=i%10;
                      i/=10;
              }while (i > 0);
              return ans;
     }
     int isDevided(int num, int dev){
             if (num%dev == 0) return 1;//devided
             else return 0; // not devided
     }
     int main(){
             cout << "Enter a number, please" << endl;<br>             int i = 0;
             cin >> i;
             int sum = getSum(i);
             cout << "Sum of the digitn in the number  = " << sum << endl;<br>             if (isDevided (i - sum, 9)) cout << "OK/n";<br>             else cout << "FAIL!";<br>             return 0;
    


(23 баллов)