Напишите программу, которая вычисляет сумму цифор только трехзначных чисел

0 голосов
59 просмотров

Напишите программу, которая вычисляет сумму цифор только трехзначных чисел


Информатика (15 баллов) | 59 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c,d:integer;
begin
writeln('Введите число:');
readln(a);
if (a div 1000=0) and (a div 100>0)  then begin
b:=a div 100;
c:=a div 10 - (a div 100) * 10;
d:=a - (a div 10)*10;writeln(b+c+d);
end
else writeln('Вы ввели не трехзначное число.');
end.

(313 баллов)
0

Можно заменить в условии эти 4 оператора на:
b:=a div 100;
c:=a div 10 - (a div 100) * 10;
d:=a - (a div 10)*10;writeln(b+c+d);
на вот этот:
writeln(a div 100+a div 10 - (a div 100) * 10+a - (a div 10)*10;writeln(b+c+d))

0

*writeln(a div 100+a div 10 - (a div 100) * 10+a - (a div 10)*10;
И тогда можно вырезать из var: b,c,d

0

Получится:
var a:integer;
begin
writeln('Введите число:');
readln(a);
if (a div 1000=0) and (a div 100>0) then begin
writeln(a div 100+a div 10 - (a div 100) * 10+a - (a div 10)*10);
end
else writeln('Вы ввели не трехзначное число.');
end.