Помогите пожалуйста сделать информатику

0 голосов
42 просмотров

Помогите пожалуйста сделать
информатику


image

Информатика (48 баллов) | 42 просмотров
0

Необходимо написать программу? На каком языке программирования?

0

без понятия сможешь сделать как ты знаешь?

Дан 1 ответ
0 голосов

{Дано трехзначое число.
Найти число полученное при перестановке первой и второй цифры}
var N:integer;
begin
 writeln('введите трехзначное число 99 readln(N);
 {(n mod 10)- третья цифра,  (n div 10) mod 10 - вторая цифра}
 {(n div 100) mod 10 - первая цифра}
 n:= (n mod 10)*100+((n div 10) mod 10)*10+(n div 100) mod 10;
 writeln(N);
end.

{Дано четырехзначое число.
Найти сумму и произведение цифр числа}
var N, p, sum, i:integer;
    C:byte;
begin
 writeln('введите четырехзначное число');
 readln(N);
 p:=1 ; sum:=0;
 for i:=1 to 4 do
 begin
  c:=n mod 10; {последняя цифра числа}
  n:=n div 10; {отбрасываем последнюю цифру числа}
  sum:=sum+c;
  p:=p*c;
 end;
 writeln(sum:8, p:8);
end.


(846 баллов)