Составьте программу выводящую ** экран таблицу значении функции y=4x-5 ** отрезке (1;30)...

0 голосов
32 просмотров

Составьте программу выводящую на экран таблицу значении функции y=4x-5 на отрезке (1;30) с шагом h=3
Пожалуйста помогите даю 57 баллов


Информатика (53 баллов) | 32 просмотров
0

29 а не 57, читайте правила, баллы делятся на двух ответчиков

Дано ответов: 2
0 голосов
Правильный ответ

Язык не указан, решение будет приведено на двух языках: наиболее популярном в школах Pascal и, на мой взгляд, незаслуженно считающемся "детским и непрофессиональным" BASIC (в примитивной его версии qBASIC). Как можно будет убедиться, в Бейсике программа получается даже короче и, я бы сказал, даже нагляднее..
Pascal:
var
  x:integer;
begin
  x:=1;
  Writeln(' x  y=4x-5');
  while x<30 do<br>  begin Writeln(x:2,4*x-5:6); x:=x+3 end
end.

Результат выполнения программы:
 x  y=4x-5
 1    -1
 4    11
 7    23
10    35
13    47
16    59
19    71
22    83
25    95
28   107

qBASIC:
PRINT " x           y=4x-5"
FOR x = 1 TO 30 STEP 3
   PRINT x, 4 * x - 5
NEXT x
END

Результат выполнения программы:
 x           y=4x-5
 1            -1
 4             11
 7             23
 10            35
 13            47
 16            59
 19            71
 22            83
 25            95
 28            107

(142k баллов)
0 голосов

Var x,y:real;
i,h:integer;
begin
h:=3;
writeln ('y=4x-5');
WRITELN;
writeln ('x    y');
for i:=1 to 10 do
begin
y:=4*h-5;
writeln (h,'    ',y);
h:=h+3;
end;
end.


image
(10.7k баллов)