Написать программу в Pascal числа a,b и c вводятся с клавиатуры.найти...

0 голосов
67 просмотров

Написать программу в Pascal
числа a,b и c вводятся с клавиатуры.найти max(a,a+b)+max(a,b+c)/1+max(a+b*c,1,5)


Информатика (31 баллов) | 67 просмотров
0

Какая версия Паскаля?

0

А еще - какой смысл делить на единицу?

0

Есть пару вопросов:1) Pascal ABC или Free Pascal2) как понять max? Оно каждый раз сравнивает какое из этих больше и вставляет или другой смысл?

0

Pascal abc

0

На самом деле еще вопрос - в последнем max для чего 1 и 5 сравнивать?

0

Я не знаю,просто меня не было на уроке и тему я пропустил

0

Почти уверен, что условие неверно написано

0

Тема урока предыдущего функции?

0

Ага

0

Тогда вроде бы понял. Сейчас пришлю.

Дано ответов: 2
0 голосов
Правильный ответ

Function max (var first,second:real): real;
begin 
if first > second then max:=first else max:= second;
end;

var a,b,c,y : real;
begin 
writeln('Ведите a,b,c через пробел и нажмите Enter: '); 
 read(a,b,c); 
y:= max(a,a+b)+max(a,b+c)/1+max(a+b*c,1.5); 
 writeln('Ответ: ',y);
end.

(1.0k баллов)
0 голосов
Уверен, что формула в условии написана неверно, но уж как написано...

var
  a,b,c:real;
begin
  Write('Введите a,b,c: '); Read(a,b,c);
  Writeln('Результат: ',max(a,a+b)+max(a,b+c)/1+max(max(a+b*c,1),5))
end.

Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 31

А вот так, на мой взгляд, должно быть:
var
  a,b,c:real;
begin
  Write('Введите a,b,c: '); Read(a,b,c);
  Writeln('Результат: ',(max(a,a+b)+max(a,b+c))/(1+max(a+b*c,1.5)))
end.

Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 0.6

(142k баллов)