Составьте программу,которая формирует массив из 40 случайных целых чисел от 0 до 20 и...

0 голосов
56 просмотров

Составьте программу,которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет сумму чисел,не превышающих 10


Информатика (55 баллов) | 56 просмотров
Дан 1 ответ
0 голосов

program pr;

var mas:array[1..40] of integer;

i, sum:integer;

begin

randomize;

for i:=1 to 40 do mas[i]:=random(20);

for i:=1 to 40 do if mas[i]<=10 then sum:=sum+mas[i];</p>

writeln ('сумма равна ', sum);

readln;

end.

Программу проверил все работает

(496 баллов)