Написать программу которая по номеру дня недели выдаст название дня и количество уроков в...

0 голосов
131 просмотров

Написать программу которая по номеру дня недели выдаст название дня и количество уроков в вашем классе .В Паскале .Ps уроков у нас 6 каждый день .кроме среды. в среду 7 уроков


Информатика (20 баллов) | 131 просмотров
0

А субботы занимаетесь?

0

да

0

Какая версия Паскаля?

0

ой а этого я не знаю

0

PascalABC вот это наверное .я не в курсе

Дано ответов: 2
0 голосов
Правильный ответ

Пронумеруем дни недели числами от 0 до 6 (0-Вс, 1-Пн, .. 6-Сб).

var
  dow:0..6;
begin
  Write('Введите номер дня недели (0-Вс, 6-сб): ');
  Read(dow);
  case dow of
  0:Writeln('Воскресенье, выходной');
  1:Writeln('Понедельник, 6 уроков');
  2:Writeln('Вторник, 6 уроков');
  3:Writeln('Среда, 7 уроков');
  4:Writeln('Четверг, 6 уроков');
  5:Writeln('Пятница, 6 уроков');
  6:Writeln('Суббота, 6 уроков');
  else Writeln('Введено неверное значение')
  end
end.

Тестовое решение:
Введите номер дня недели (0-Вс, 6-сб): 5
Пятница, 6 уроков



(142k баллов)
0

спасибо огромное .а то завтра зачет

0

Пожалуйста

0 голосов

Program al;
Var
  x: integer;
BEGIN
Repeat
Write('VVedite cislo ot 1 äî 7: ');
 Readln(x);
until x in [1..7];
Case x of
  1: Writeln('Ponidelnik-6urokov');
  2: writeln('Vtornik-6erokov');
  3: writeln('Sreda-7urokov');
  4: writeln('Cetverg-6urokov');
  5: writeln('Piatnita-6urokov');
  6: writeln('Subbota-6urokov');
  7: writeln('Voskresenie-vihadnoy');
end;
Readln
END.