СРОЧНО! Помогите, пожалуйста по информатике! Нужно написать программу в Паскаль: Дано 3-х...

0 голосов
16 просмотров

СРОЧНО!
Помогите, пожалуйста по информатике!
Нужно написать программу в Паскаль:
Дано 3-х значное число. Определите, есть ли там одинаковые числа.


Информатика (477 баллов) | 16 просмотров
Дан 1 ответ
0 голосов

Program z1;
var x,y,x1,x2,x3
begin
readln(x);
x1:= x div 100;
x2:= x mod 10;
x3:=x mod 100;
if x1 =x2 then  y:=y+1 else 
  if x1=x3 then  y:=y+1 else
    if x2=x3 then y:=y+1 else y:=0;
if y>=1 then write  ('est') else write ('netu')
end.

(51 баллов)
0

Спасибо!