Написать программу, которая сможет определить, есть ли среди цифр заданного целого...

0 голосов
60 просмотров

Написать программу, которая сможет определить, есть ли среди цифр заданного целого трёхзначного числа одинаковые. Даны три переменные вещественного типа: A, B, C. Если их значения упорядочены по возрастанию или убыванию, то удвоить их; в противном случае заменить значение каждой переменной на противоположное. Вывести новые значения переменных A, B, C.


Информатика (76 баллов) | 60 просмотров
Дан 1 ответ
0 голосов

1. 

var
n, a, b, c: integer;

begin
readln(n);
a := n div 100;
b := n div 10 mod 10;
c := n mod 10;
if (a = b) or (b = c) or (a = c) then writeln('YES')
else writeln('NO');
end.

 

2.

var
a, b, c: real;

begin
readln(a, b, c);
if ((a < b) and (b < c)) or ((a > b) and (b > c)) then begin a := a * 2;b := b * 2;c := c * 2; end
else begin a := -a;b := -b;c := -c; end;
writeln(a,' ', b,' ', c);
end.

(652 баллов)