Составьте программу которая формирует массив из 15 случайных целых чисел от -20 до 20 и...

0 голосов
29 просмотров

Составьте программу которая формирует массив из 15 случайных целых чисел от -20 до 20 и чётные числа делятся на 2 и нечетные умножается на 3


Информатика (32 баллов) | 29 просмотров
Дан 1 ответ
0 голосов

Program zd;var mas:array [1..15] of integer;i:integer;beginrandomize;for i:=1 to 15 do beginmas[i]:=random (20)-10;end;for i:=1 to 15 do beginif mas[i] mod 2 = 0 then mas[i]:=mas[i] div 2;if mas[i] mod 2 = 1 then mas[i]:=mas[i]*3;end;for i:=1 to 15 do beginwriteln ('',mas[i]);end; end.

(114 баллов)
0

program zd;
var mas:array [1..15] of integer;
i:integer;
begin
randomize;
for i:=1 to 15 do begin
mas[i]:=random (20)-10;
end;
for i:=1 to 15 do begin
if mas[i] mod 2 = 0 then mas[i]:=mas[i] div 2;
if mas[i] mod 2 = 1 then mas[i]:=mas[i]*3;
end;
for i:=1 to 15 do begin
writeln ('',mas[i]);
end;
end.