Помогите , пожалуйста, написать программу ** паскале ! :))) 1 1 3 1 3 5 1 3 5 7 1 3 5 7 9...

0 голосов
33 просмотров

Помогите , пожалуйста, написать программу на паскале ! :)))
1
1 3
1 3 5
1 3 5 7
1 3 5 7 9
нужно вывести числа в таком порядке ( в паскале)


Информатика (16 баллов) | 33 просмотров
0

просто вывести?

Дан 1 ответ
0 голосов

Var
a,b,i,i2:integer;
Begin
Readln(a);
b:=1;
for i:=1 to a do begin
if b mod 2 = 0 then b:=b+1;
for i2:=1 to b do if i2 mod 2 <>0 then Write(i2,' ');
b:=b+1;
Writeln();
end;
End.

(875 баллов)
0

крч a здесь - количество строчек которое ты хочешь получить

0

что означает этот знак ?

0

можно обойтись без него ?

0

<>

0

этот знак

0

:)

0

это не равно

0

не так

0

это "не равно"