Напишите программу, которая получает ** вход 4х-значное число и выдает суммы 1ой и 4ой...

0 голосов
54 просмотров

Напишите программу, которая получает на вход 4х-значное число и выдает суммы 1ой и 4ой цифр, а также 2ой и 3ей


Информатика (705 баллов) | 54 просмотров
0

на паскале

Дан 1 ответ
0 голосов
Правильный ответ

Var a,a4,a3,a2,a1:integer;
begin
readln(a);
a4:=a mod 10;
a:=a div 10;
a3:=a mod 10;
a:=a div 10;
a2:=a mod 10;
a:=a div 10;
a1:=a mod 10;
writeln(a4+a1);
write(a3+a2);
end.

(1.7k баллов)