Составить программу которая выбросит из записи числа n все цифры равные 1, оставив при...

0 голосов
79 просмотров

Составить программу которая выбросит из записи числа n все цифры равные 1, оставив при этом прежним порядок остальных цифр. Пример 5101234-50234


Информатика (22 баллов) | 79 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s:=ReadlnString.Where(x->x in ['0'..'9']);
  var r:=s.Where(x->x<>'1').Println('');
end.

Тестовые примеры:
5101234
50234

3,1415926535897932384626433832795028 - первые знаки числа ПИ
345926535897932384626433832795028

98765432111111111110000111111000001111111123456789
9876543200000000023456789

(142k баллов)
0 голосов
#include
#include
#include
#include
#include
#include
#include
#include
#include
#include

#include
#include
#include
#include
#include
#include
#include
#include
#include
#include
typedef unsigned long long ulol;
typedef long long lol;
typedef long int  li;
#define mp          make_pair
#define F           first
#define S           second
#define sqr(a)      ( (a) * (a) )
#define pb          push_back
#define INF         999999999
#define ret(a)      cout << endl; system("pause"); return(a)<br>//#define ret(a)      return(a)
using namespace std;int main()
{
    string s, ans;
    cin >> s;
    for(int i = 0 ; i < s.size() ; i ++)
        if( s[i] != '1' )
            ans.pb( s[i] );
    cout << ans;<br>    ret(0);
}
(82 баллов)
0

А тебе не приходило в голову, то что все проги я пишу в этом файле и мне не удобна вечно подключать библиотеки. Я не говорил, что я топ прогер... язык топовый. а если ты не знаешь, что такое bitset или map это не мое дело. Кому надо тот все изменит под себя. Я даю лишь идею решения. А язык я и так прекрасно знаю... разве что побитовые маски сам не пишу...

0

удобно*

0

а про длину кода?

0

напиши на паскале qsort

0

#include
using namespace std;
int main()
{
long long n;
cin >> n;
ar[n];
sort(ar, ar+n);
for(itn I = 0 ; i < n ; i ++ )
cout << ar[i] << ' '; <br>return 0;
}

0

вот выше кд qsort

0

в паскале = 40+ строк

0

Зачем писать про 40+ строк в Паскале, когда под Вашим сообщением в Паскале решение из четырех строк?

0

qsort Вы возжелалось посмотреть на Паскале? Пожалуйста, 10 строчек. Отправил в ЛС вместе с контрольным примером))