Напишите программу в Pascal , которая из трех введенных с клавиатуры чисел возводит в...

0 голосов
138 просмотров

Напишите программу в Pascal , которая из трех введенных с клавиатуры чисел возводит в квадрат положительные, а отрицательные оставляет без изменения.


Информатика | 138 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
a, b, c: integer;
begin
readln(a, b, c); //вводим a b c
if a > 0 then writeln(a*a) //если a > 0 вывести квадрат a
else
writeln(a); //иначе вывести a
if b > 0 then writeln(b*b) //если b > 0 вывести квадрат b
else
writeln(b); //иначе вывести b
if c > 0 then writeln(c*c) //если c > 0 вывести квадрат c
else
writeln(c); //иначе вывести c
end.

(15.5k баллов)
0

да. могу прицепить скрин работы)