Составить программу, решающую следующую задачу: Вы покупаете товар, и у Вас имеются...

0 голосов
63 просмотров

Составить программу, решающую следующую задачу: Вы покупаете товар, и у Вас имеются монеты номиналом 1, 2, 5, 10 рублей. Наберите необходимую сумму товара в N рублей так, чтобы она состояла из минимального количества монет. язык паскаль


Информатика (113 баллов) | 63 просмотров
0

Лучшим сделаешь?

Дан 1 ответ
0 голосов
Правильный ответ

Program noname;
var a,b,c,d,e;
begin
readln(a);
b:=a div 10;
a:=a-b;
c:=a div 5;
a:=a-c;
d:=a div 2;
a:=a-d;
e:=a;
writeln('Десяток:',b);
writeln('Пятёрок:',c);
writeln('Двоек:',d);
writeln('Единиц:',e);
writeln('Всего монет:'(b+c+d+e));
end.

(646 баллов)
0

сделай лучшим