Составьте программу ** языке Паскаль. Среди 15 случайных чисел из диапазона (-25;15)...

0 голосов
31 просмотров

Составьте программу на языке Паскаль. Среди 15 случайных чисел из диапазона (-25;15) найти количество чисел, делящихся на 5, но не делящихся на 10.


Информатика (15 баллов) | 31 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,k,i:integer;
begin
Randomize;
k:=0;
for i:=1 to 15 do
 begin
 a:=random(41)-25;
 write(a,'  ');
 if abs(a) mod 10 = 5 then k:=k+1;
 end;
writeln;
writeln('k = ',k);
end.

Пример:
-6  -20  -24  -22  10  -18  -10  10  -5  -12  9  -24  15  1  -15  
k = 3

(194k баллов)
0

спасибо огромное!

0

Пожалуйста.