Написать программу ** Паскале для решения следующей задачи: Дан массив из 20 элементов....

0 голосов
88 просмотров

Написать программу на Паскале для решения следующей задачи: Дан массив из 20 элементов. Необходимо посчитать количество пар элементов, в которых есть хотя бы 1 нечетный элемент. Под парой элементов считать 2 рядом стоящих элемента.


Информатика (29 баллов) | 88 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
  var a:=ArrRandom(ReadInteger('n='),-30,30);
  a.Println;
  var b:=a.Pairwise.Where(i->(i.Item1.IsOdd) or
    (i.Item2.IsOdd)).Count;
  Writeln('Количество пар= ',b)
end.

Тестовое решение:
n= 15
-5 7 12 -11 29 11 -28 19 20 28 -6 30 26 -14 27
Количество пар= 9

(142k баллов)
0

а можно по человечески?

0

полегче что нибудь

0

Скачайте её с официального сайта и убедитесь, что все работает.

0

Да хоть сто раз var - Паскалей множество. Эта версия позволяет писать так.

0

Надо писать версию языка, которую Вы изучаете

0

у вас тут 2 раза var

0

Если Вы чего-то тут не понимаете, то это не значит, что написано "не по-человечески"

0 голосов

Const
  n = 20;

var
  a: array[1..n] of integer;
  m, i: integer;
begin
  for i := 1 to n do
  begin
    a[i] := random(21) - 10;
    write(a[i]:4);
  end;
  writeln;
  for i := 1 to n - 1 do
    if (a[i] mod 2 <> 0) or (a[i + 1] mod 2 <> 0) then m := m + 1;
  writeln('Всего пар', m);
end.

Тестовое решение:
   2  -8   8  -5   7  -8  -3  -6  -9   2  -1  -3  -8   6  10   7  -4  -8   0  -5
Всего пар 13


(13.9k баллов)
0

Это сможет и семиклассник написать. Если заниматься будет, как положено.

0

Ну так и пользуйтесь тем, что понятно, для этого и служат ДВА ответа, чтобы выбрать себе по уровню.

0

по другим у меня пятерки

0

у меня с информатикой кое-как((

0

нет, второе мне понятно

0

А тут либо не повезло с учеником, либо с учителем, либо это все одновременно))

0

Интересно, а что в этом коде непонятно 9-и класснику?

0

но то что вы написали это точно 9-классник не сможет написать

0

спасибо

0

А потом задание попадет в архив, при поиске кто-то выберет то, что ему ближе.