Нужно написать программу ** языке Паскаль, которая будет убирать из строки все символы...

0 голосов
50 просмотров

Нужно написать программу на языке Паскаль, которая будет убирать из строки все символы кроме цифр. Пример: входной- a3f4h5k&2 выходной:3452


Информатика (595 баллов) | 50 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  var s:=ReadlnString;
  s:=s.Where(d->d in ['0'..'9']).JoinIntoString('');
  Writeln(s)
end.

Тестовое решение:
a3f4h5k&2
3452

(142k баллов)
0 голосов

Var s:string;
l,i:longint;
begin
read(s);
l:=length(s);
for i:=1 to l do
if (s[i]>='0')and(s[i]<='9') then write(s[i]);<br>end.

(2.0k баллов)
0

а без OR можно как нибудь?

0

без понятия

0

можно наверное

0

но я не настолько хорошо стринг знаю

0

там блин как-то диапозон можно выставить, а я забыл как =)

0

if (s[i] >= '0') and (s[i] <= '9')<br>По стандарту языка, вроде как, цифры должны идти по порядку

0

да, ты прав

0

А где удаление символов из строки, как в задании написано?

0

там смотри условие, если данный символ число то печатать его крч =)