Написать программу ** паскаль авс программа должна через функцию определять чётность...

0 голосов
26 просмотров

Написать программу на паскаль авс
программа должна через функцию определять чётность кол-ва символов в строке
например: Маша - чётный 4 ; Маша_ - нечётный 5


Информатика (30 баллов) | 26 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
a: string;
b: integer;
begin
readln(a);
b:=length(a);
if b mod 2 = 0 then writeln('Кол-во символов четное')
else writeln('Кол-во символов нечетное')
end.

(98 баллов)
0

а можешь сделать так чтобы считало кол-во символов?

0

тоесть маша 4

0

мам 3

0 голосов
program MW10; var a:string; var i,k:integer; begin Writeln('Wwedi slovo'); Read(a); for i:= 1 to length(a) do if a[i]='a' then k:=k+1; writeln(k); end.
(56 баллов)