Помогите написать программу в Паскале: Некоторая сумма денег выражена в копейках,...

0 голосов
87 просмотров

Помогите написать программу в Паскале: Некоторая сумма денег выражена в копейках, например 317, 5050, 100. Записать данную сумму в рублях и копейках, т. е. В виде: 3 руб. 17 коп., 50 руб. 50 коп., 1 руб. 00 коп. (Количество копеек всегда выражается двумя цифрами).


Информатика (834 баллов) | 87 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

{В данном случае не имеет смысла возиться с числами, куда лучше подходят строки}
//Pascal ABC.NET v3.1 сборка 1172

Var
 s,c:string;
begin
 readln(s);
 c:=s[length(s)-1]+s[length(s)];
 delete(s,length(s)-1,2);
 writeln(s,' руб. ',c,' коп.');
end.

Пример ввода:
8705553535
Пример вывода:
87055535 руб. 35 коп.


(38.6k баллов)