Паскаль. Нужно написать программу с массивами для викторины. Я написала, но она работает...

0 голосов
41 просмотров

Паскаль. Нужно написать программу с массивами для викторины. Я написала, но она работает не полноценно, задаётся только первый вопрос, в чём ошибка? помогите


image
image

Информатика (12 баллов) | 41 просмотров
0

Ошибок не вижу. Может, дело в таком прекрасном модуле crt?

0

Вот весьма утрированный вариант Вашего кода. Работает идеально, только значения и тип массивов поменяйте.

0

Const n=10;Var ans,que,answ:array[1..n] of integer; i:integer;begin for i:=1 to n do begin ans[i]:=i; que[i]:=i; end; for i:=1 to n do begin writeln('Que', i); writeln(que[i]); write('Answ:'); readln(answ[i]); if answ[i]=ans[i] then writeln('True') else writeln('False'); end;end.

0

спасибо огромное

Дан 1 ответ
0 голосов

Попробуйте вынести проверку условия в отдельный цикл.

(26 баллов)
0

как это сделать?