Помогите пожалуйста! Дам 20 б 1) Написать программу, которая попросит ввести два числа, а...

0 голосов
29 просмотров

Помогите пожалуйста! Дам 20 б
1) Написать программу, которая попросит ввести два числа, а затем спросит, что с ними нужно сделать: сложить или перемножить. Результат вывести на экран.
2) Школьники Иванов и Петров за время летних каникул заработали определённую сумму. Кто их них заработал большую сумму? Определить средний заработок. (написать программу)


Информатика (102 баллов) | 29 просмотров
Дан 1 ответ
0 голосов

Var a, b: integer;
var c: string;
begin
writeln('Введите 1 число.');
readln(a);
writeln('Введите 2 число.');
readln(b);
writeln('Знак операции.');
readln(c);
if c='*' then writeln(a*b);
if c='/' then writeln(a/b);
if c='-' then writeln(a-b);
if c='+' then writeln(a+b);
end.
2 ЗАДАЧА 
var a, b: real;
begin
writeln('Зарабаток Пети:');
readln(a);
writeln('Зарабаток Петрова:');
readln(b);
if a>b then writeln('Петя заработал больше Петрова.')
else if a=b then writeln('Петров и Петя заработали одинаково.')
else
writeln('Петров заработал больше Пети.');
writeln('Среднее: ', (a+b)/2);
end.

(312 баллов)
0

Объясните подробнее 2 задание, что должна делать программа, я дополню решение.

0

Вероятно, нужно сделать так, чтобы программа определила средний заработок и посчитала, кто заработал большую сумму. Просто в задании больше ничего не написано. И спасибо за решение 1-ого задания)

0

А как рассчитывать среднее там формулы нет?

0

Среднее арифметическое например (5+5)/2, так что-ль?

0

Наверное, да. Вообще, мы такое на информатике ещё не проходили, не знаю, почему задали

0

Ну хорошо, сейчас напишу продолжение:)

0

Ответ дополнен

0

Спасибо огромное! :-)

0

;)