Напишите программу, которая находит номер максимального элемента массива.

0 голосов
112 просмотров

Напишите программу, которая находит номер максимального элемента массива.


Информатика (37 баллов) | 112 просмотров
Дан 1 ответ
0 голосов

C#
int n = Convert.ToInt32(Console.ReadLine());
int max = 0;
int index = -1;
int [] mass = new int [n];
Random rnd = new Random();

for (int i = 0; i< mass.Length; i++)
{
mass[i] = rnd.Next();
Console.WriteLine(mass[i] + " ");
}

for (int i = 0; i < mass.Length; i++)
{
if (mass[i] > max)

max = mass[i];
index = i;
}
}
Console.WriteLine("Индекс наибольшего равен " + index);

короч просто описываю что надо:
1) Заводишь переменные для максимума и индекса
2) Заполняешь массив рандомными числами
3) выводишь массив
4) пробегаешь по массиву, сверяя элементы с максимумом
- если max меньше элемента, то присваиваешь ему элемент и запоминаешь в index номер элемента
5) выводишь индекс элемента

в коде все понятно будет, я думаю
но я думаю вам нужен паскаль, но на паскале я не могу с массивами, не люблю я их.

(1.2k баллов)
0

а можно в паскале

0

спс за C#