Надо написать программу в Free Pascal. по данному значению x вычислите функции y,учитывая...

0 голосов
43 просмотров

Надо написать программу в Free Pascal.

по данному значению x вычислите функции y,учитывая область определения функции.

y=(16*x^2 / x-2)+3

/-это дробь


Информатика (12 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

var
x:integer;
y:real;
begin
writeln('Vvedite x');
readln(x);
if (x>0) and (x<>2) or (x<0) then<br>begin
y:=(16*sqr(x))/(x-2)+3;
writeln('y = ',y:2:2);
end
else
writeln('X ne vxodit v oblast opredeleniya');
end.

(1.3k баллов)