Напишите программу которая вводит трехзначное число и ,,вырезает '' из него 1 и последнюю цифру
на каком языке? Паскаль? Си? Си++?
Паскаль и бэйсик
ну хотя-бы паскаль
*четырехзначное
//PascalABC.NET var a:integer; begin readln(a); writeln(a div 10 mod 10); end. //Для 4 значного //PascalABC.NET var a:integer; begin readln(a); writeln(a div 100 mod 10, a div 10 mod 10); end.
Вырезает как я понял значит удаляет.
a div 10 для трехначного числа выдаст 2 первых числа, а не 1.
a div 10 mod 10 среднее число
тогда просто (a mod 100) без всяких div
Ну по идее пишешь 1234 получаешь 23
Трехзначное же число по учловию
Блин это мой касяк , извени
Кстати, при a mod 100 выводятся последнее 2-е цифры
А как будет с четырехзначным числом? если не сложно
//PascalABC.NET var a:integer; begin readln(a); writeln(a div 100 mod 10, a div 10 mod 10); end.
Program Project; uses crt; var a: byte; begin clrscr; Write("Введите число "); Readln(a); Writeln("Полученные числа:",(a div 100)," ",(a mod 10)); Readln; end.