Написать программу, которая выводит ** экран сообщение (да или нет), равна ли сумма...

0 голосов
45 просмотров

Написать программу, которая выводит на экран сообщение (да или нет), равна ли сумма первых двух цифр заданного трехзначного числа последней цифре этого числа. (Например: 123, т.к. 1+2=3). (Используются операторы div и mod)


Информатика (863 баллов) | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var  a: integer;
begin
  read(a);
  if((a div 100)+(a mod 100 div 10)=(a mod 100 mod 10)) then write('Да') 
else write('Нет');
end.

(6.9k баллов)