Паскаль! Напишите программу, которая определяет, верно ли, что введённое число содержит...

0 голосов
101 просмотров

Паскаль!
Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).


Информатика (543 баллов) | 101 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  n,i:integer;
  s:string;
begin
  Write('Введите натуральное число: '); Read(n);
  Str(n,s);
  for i:=2 to Length(s) do
    if s[i]=s[i-1] then begin
      Writeln('Пара одинаковых цифр-соседей ',s[i]);
      Exit
      end;
  Writeln('В числе нет цифр, имеющих таких же соседей')
end.

Пример
Введите натуральное число: 375422453
Пара одинаковых цифр-соседей 2

(150k баллов)