Напишите программу,которая анализирует человека по возрасту и относит к одной из пяти...

0 голосов
221 просмотров

Напишите программу,которая анализирует человека по возрасту и относит к одной из пяти групп:дошкольник,школьник,студент,работник,пенсионер.Возраст вводится с клавиатуры.Используйте оператор CASE.


Информатика (17 баллов) | 221 просмотров
Дано ответов: 2
0 голосов

var

 n:byte;

begin

  write ('Vozrast: ');

  readln(n);

  case n of

   1..6:writeln ('Дошкольник');

   7..18:writeln ('Школьник');

   19..24:writeln ('Студент');

   25..55:writeln ('Работник');

   56..110:writeln ('Пенсионер'); 

   else writeln ('Не факт,что доживет');

  end;

  readln;

end.

(2.8k баллов)
0 голосов

Пишем и объяснем. Элемент case - это оператор аналогичный if, только условия более "скомпованы". Для того, чтобы не вводить 10 раз if используют case. Разбираем.

 

Uses crt;

 

Var n:real; //нужен только переменная возраста

 

Begin

Writeln('введите возраст человека'): read(n); //считываем возраст с клавиатуры

Case n of:                                                // таким образом объявляется этот оператор

0..6: writeln('Дошкольник');                                 // пишим всякие числовые значения

7..18: writeln('Школьник');                                   // которые можно менять.

18-24: writeln('Студент');                                    //  Технология

25-60: writeln('Работник');                                  // аналогичная оператору if

60-100: wtiteln('Пенсионер');                       

    end;            // обязательно end в конце - конец условия опертора

end.

 

 

(1.7k баллов)