Помогите.Информатика 9 класс.Составьте программу которая формирует массив из 16 случайных...

0 голосов
76 просмотров

Помогите.Информатика 9 класс.Составьте программу которая формирует массив из 16 случайных целых чисел от -20 до 20 и находит элемент с нулевым значением


Информатика (12 баллов) | 76 просмотров
Дан 1 ответ
0 голосов

// PASCAL

var
  a: array [1..16] of integer;
  i: integer; b: boolean;

begin
  randomize;
  for i := 1 to 16 do a[i] := random(-20, 20);
  for i := 1 to 16 do
    if a[i] = 0 then begin
      if b then write(', ');
      write(i, '-й ');
      b := true;
    end;
  if b then writeln('элемент(ы) равен(ны) нулю') else writeln('В массиве нету элементов, равных нулю.');
end.

(386 баллов)