Написать программу по "Из трехзначного числа Х вычли его последнюю цифру.Когда результат...

0 голосов
86 просмотров

Написать программу по "Из трехзначного числа Х вычли его последнюю цифру.Когда результат разделили на 10,а к частному слева приписали последнюю цифру числа Х,то получилось число 237.Найти число Х." Язык Pascal.

Заранее благодарна.


Информатика (36 баллов) | 86 просмотров
Дан 1 ответ
0 голосов

Var ch,ci,x,y:integer;
begin
y:=237;
ci:=(y div 100);
ch:=(y mod 100);
x:=ch*10+ci;
writeln(x);
end.

(116 баллов)