Напишите программу, которая выводит ** экран все простые числа в диапазоне от 1 до числа,...

0 голосов
62 просмотров

Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры.


Информатика (33 баллов) | 62 просмотров
Дан 1 ответ
0 голосов

Var
i, j, n : integer;
flag : boolean;
begin
write('n = ');
read(n);
for i := 2 to n do begin
flag := true;
for j := 2 to i-1 do
if (i mod j = 0) then begin
flag:=false;
break;
end;
if flag = true then write(i, ' ');
end;

(25 баллов)