Написать ПРОГРАММУ и составить БЛОК СХЕМУ по этим задачам: 1)Дан массив из десяти целых...

0 голосов
51 просмотров

Написать ПРОГРАММУ и составить БЛОК СХЕМУ по этим задачам:
1)Дан массив из десяти целых чисел. Определите, сколько элементов этого массива имеют максимальное значение.
2)В классе 20 учеников писали диктант по русскому.Написать программу и блок-схему подсчета кол-во оценок 2 3 4 5 получивших за диктант(писать через массив).
3)Объявлен набор в школьную баскетбольную команду.Известен рост каждого из n учеников желающих попасть в эту команду. Составьте алгоритм подсчета и блок схему количества претендентов имеющих шанс попасть в команду если рост игрока команды должен быть не менее 170 см.Запишите на языке Паскаль программу.Считайте рост претендентов случайным числом из диапазона 150-200 см, а число претендентов n=50.


Информатика (56 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

1)var
  a: array[1..10] of integer;
  m, i,s: integer;

begin
  randomize;
  for i := 1 to 10 do 
  begin
    a[i] := random(+10) + 1;
    if a[i] > m then m := a[i];
  end;
  for i := 1 to 10 do 
  begin
    if a[i]=m then s:=s+1;
  end;
  writeln(s);
end.
2)var

(298 баллов)
0

А блок схемы?