Уровень А. (оценка 3). Напишите программу, которая выводит M линий из символа S,...

0 голосов
31 просмотров

Уровень А. (оценка 3). Напишите программу, которая выводит M линий из символа S, заданного пользователем длиной N символов. При запуске программы M, N, S нужно ввести с клавиатуры. Пример: Количество линий: 2. Длина цепочки: 7. Символ-заполнитель: - ------- ------- Для реализации программы напишите процедуру Line, которая принимает два параметра – символ-заполнитель S и натуральное число N, и выводит на экран одну линию из символов S длиной N. Пример: Длина цепочки: 7. Символ-заполнитель: - -------


Информатика (15 баллов) | 31 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.2 сборка 1318

Var
  m,n,i:integer;
  s:char;

procedure line(c:char;n:integer);
Var
  i:integer;
begin
for i:=1 to n do
write(c);
writeln;
end;
 

begin
readln(m,n);
readln(s);
for i:=1 to m do
line(s,n);
end.

Пример ввода:
2
7
-
Пример вывода:
-------
-------

(38.6k баллов)