Напишите программу, которая вычисляет среднюю за неделю температуру воздуха. Исходные...

0 голосов
442 просмотров

Напишите программу, которая вычисляет среднюю за неделю температуру воздуха. Исходные данные вводятся с клавиатуры. Пример входных данных. Понедельник>> 12 Вторник>>10 Среда>>16 Четверг>>18 Пятница>>17 Суббота>>16 Воскресенье>>14 Пример выходных данных Средняя температура за неделю: 14.71 Только через For


Информатика (29 баллов) | 442 просмотров
0

Вводятся только числа или как в примере?

Дан 1 ответ
0 голосов

Program example;const n=7;var sr:real;i:integer;a:array[1..n] of integer;begin sr:=0; writeln('Vvedite temperaturu za kajdyi den '); for i:=1 to n do begin  readln(a[i]);  sr:=sr+a[i]; end; sr:=sr/7; write('Srednya temperatura = ',sr:0:2); readkey;end.

(8.0k баллов)
0

program example;const n=7;
var sr:real;
i:integer;
a:array[1..n] of integer;
begin
sr:=0;
writeln('Vvedite temperaturu za kajdyi den ');
for i:=1 to n do begin
readln(a[i]);
sr:=sr+a[i];
end;
sr:=sr/7;
write('Srednya temperatura = ',sr:0:2);
readkey;
end.

0

Можно было короче и без массивов, меньше памяти будет требовать