Pascal. Составить программу, в которой с помощью оператора while посчитать сумму ряда ...

0 голосов
46 просмотров

Pascal. Составить программу, в которой с помощью оператора while посчитать сумму ряда ∑ \frac{5}{ i^{2}-1 } тех пор пока член ряда не будет меньше 0.005.


Информатика (53 баллов) | 46 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const e=0.005;
var i:integer;
a,s:real;
begin
i:=2;
a:=5/(i*i-1);
s:=0;
while a>=e do
 begin
 s:=s+a;
 i:=i+1;
 a:=5/(i*i-1);
 end;
writeln('i = ',i,' s = ',s);
end.

Результат:
i = 32 s = 3.59122983870968

(194k баллов)